[NCLUG] Oracle system help

Steve Roths sroths1 at attbi.com
Fri Feb 1 21:12:45 MST 2002

I got it fixed!  (huge sigh of relief)  Thank you, Mark.

I cleaned up the conf.modules file and got rid of all 'options' (don't know
why they renamed it modules.conf in 7.2)

insmod 8390 worked
then insmod ne2k-pci
modprobe nfs didn't work
tried insmod nfs without luck but then modprobe nfs worked
all worked well after that- wooo-hoo!
short bit of breath-holding when rebooted to see if it took, but all was

Thanks for your help.

----- Original Message -----
From: Mark Fassler <fassler at monkeysoft.net>
To: <nclug at nclug.org>
Sent: Friday, February 01, 2002 2:31 PM
Subject: Re: [NCLUG] Oracle system help

> Oy vey...
> Well, I think that you're only mildly hosing the system... but I feel bad
> because it would seem that I'm a somewhat guilty party in the hosing...
> If you put your /etc/modules.conf back the way it was, you should be back
> to where you were (with everything working except the ethernet card).
> About all I can offer you is more background info at this point:
> When you do an "insmod <module>" the system just tries to load that one
> module.  But sometimes modules have dependencies on other modeules (the
> ne2k-pci module uses calls from the 8390 module, for example).  So, in
> order to get a module to load, you have to load all of the modules that it
> depends on as well (and those modules might have dependencies).
> So, "insmod 8390; insmod ne2k-pci" should load the module.  (I hadn't
> looked that up this morning.  Sorry.)
> "modprobe <module>" takes care of this automagically.  But "modprobe
> <module>" takes care of other things automatically as well (like aliases
> and options from the modules.conf file).  This is usually for the best,
> but sometimes some config file somewhere gets hosed up and modprobe
> doesn't work so well.
> The module dependencies are listed in
> /lib/modules/<kernel_version>/modules.dep   This file is created with the
> "depmod -a" command (which, I think, is called automagically from Redhat
> startup scripts).
> Your problem seems to be that the driver (module) won't load for the
> ethernet card.  This might be because of an io-port problem, an IRQ
> problem or something else.
> At this point, I don't really have a "standard" practice of what to do --
> I would just poke around until I find something wrong...
> --
> Mark Fassler
> fassler at monkeysoft.net
> On Fri, Feb 01, 2002 at 12:55:49PM -0700, Steve Roths wrote:
> > now, no modules load and I get a conf:4:missing module argument
> > couldn't insmod nfs either
> >
> > Am I somehow really hosing this system?
> _______________________________________________
> NCLUG mailing list
> NCLUG at nclug.org
> http://www.nclug.org/mailman/listinfo/nclug

More information about the NCLUG mailing list