[NCLUG] rpm not recognizing library

Sean Reifschneider jafo at tummy.com
Fri Dec 2 22:54:58 MST 2005

On Fri, Dec 02, 2005 at 10:28:57PM +0000, bsimpson at att.net wrote:
> error: Failed dependencies:
>         libstdc++.so.2.8 is needed by pgp-6.5.2-free3-rsaref.i386
>I copied over libstdc++.so.2.8 into /usr/lib from a FC3 installation,
>but I still get the same error.  My guess is that rpm wants to see it
>in its own database.  How do I do this?

You probably want to rebuild pgp from src.rpm so that it uses the libraries
you have installed, instead of clinging to an old binary RPM.
compat-libstdc++ provides version 2.9, but that's not going to satisfy that

How about switching to GPG instead?  It's included with FC4.

 "When you first started at Pacific Tech you were well on your way to becoming
 another Einstein and then you know what happened?"  "I got a haircut?"
Sean Reifschneider, Member of Technical Staff <jafo at tummy.com>
tummy.com, ltd. - Linux Consulting since 1995: Ask me about High Availability

More information about the NCLUG mailing list