[NCLUG] RE: [rmiug-discuss] ANN: CLUE-North meeting, 28 Nov

Siegfried Heintze siegfried at heintze.com
Sun Nov 27 19:31:24 MST 2005

Many thanks to Collins, Mark and others who helped me at the Install Fest!

I'm still having some problems with SAMBA, however. So what is a mini fix
fest? Shall I bring my desktop and notebook again like I did to the install

I've been trying to fix the problem with some generous folks at
www.tek-tips.com (a linux forum). For your convenience, I am pasting a
record of their attempts to fix my samba problem. Since you are having a
mini fix fest, perhaps some folks would like to jump in and offer some
suggestions before the meeting?

Perhaps a summary would help. I have the following three computers and no
one except battle.angel can seem to use SAMBA to mount battle.angel's samba

battle.angel fedora core 4 desktop
Brauner 192.168.104 Win2000 workstation desktop
SALES Win XP Pro wireless notebook

battle.angel is running samba and can mount it's own samba shares. Brauner
and SALES can ping battle.angel successfully. battle.angel can mount shares
on Brauner and SALES and see and edit files on both computers. Brauner can
see battle.angel's workgroup via network neighborhood but not battle.angel
itself. SALES cannot see anyone in network neighborhood. (kinda strange,
huh?) However, both brauner and SALES and mount each other's shares and edit
each other's files.

So how can I make battle.angel's shares available to brauner and SALES? See
below for what I have already tried.


(see http://www.tek-tips.com/viewthread.cfm?qid=1154992) for an html

heintze (Programmer)  	
22 Nov 05 0:07
When I log into my desktop running fedora core 4 I can say

mount -t smbfs //$ /mnt/sales -o username=siegfried

and see the files on my notebook running XP Pro. Hurray.

However, on my notebook I can say

net use p: \\\siegfried /user:siegfried password

and it says access denied. I don't know why. I'm sure that my passwords are

I have used SWAT to configure my samba server.

The notebook can ping the desktop succesfully. I turned on "encrypt
passwords". The windows notebook can see the "mygroup" default workgroup
name in network neighborhood but when I double click on the "my group" icon
there is a long pause and nothing happens. The netbios name is "BATTLE" and
I tried using "BATTLE" instead of on the "net use" command and
that did not help.

I've also tried "net view" and that never worked.

What am I doing wrong?


Here is a fragment from the smb.conf file:

comment = sieg's home directory
path = /home/siegfried
username = siegfried
valid users = siegfried, root
admin users = siegfried, root
write list = siegfried, root
read only = No
hosts allow =

Here is the smbusers file
# Unix_name = SMB_name1 SMB_name2 ...
root = administrator admin
nobody = guest pcguest smbguest
siegfried = siegfried

Inappropriate post?
If so, Red Flag it!

Check out the FAQ
area for this forum!

Start your own Tek-Tips Group! Click Here!
LawnBoy (MIS) 	
22 Nov 05 10:41
Try the net use with out the /user switch. If the path is valid and samba is
configured correctly it should prompt you for the username and pw. If it
bombs out before prompting for a password, you have samba problems.

Thank LawnBoy
for this valuable post!

Inappropriate post?
If so, Red Flag it!

Check out the FAQ
area for this forum!

cyoung (Programmer) 	
22 Nov 05 11:16
Did you setup the user under sanba?

smah (MIS) 	
22 Nov 05 13:29
I think that cyoung is on the right track.  If I remember correctly, Swat
has trouble with creating samba users.  Use smbpasswd instead.  Also what is
the Security level?

hidden75 (IS/IT--Management) 	
22 Nov 05 15:34
Post the global.

heintze (Programmer) 	
23 Nov 05 0:12
Thanks. I tried that on the linux machine: "smbpasswd -a siegfried" and I
entered a password.

Then on the notebook I type "net use p: \\\siegfried"
it then says
Enter the username for '':
and I type "siegfried"
and then (after a long pause) it asks for the password and I type the

I get

"System error 53 has occurred."
The network path was not found.

I can ping it tho'.

Thanks -- any other ideas to try?

What does "post the global" mean?
How do I check the security level?


cyoung (Programmer) 	
23 Nov 05 10:45
Are you sure that your username/password are the same? The case has to be
the same.

Also, you may want to go read the documentation at www.samba.org on
connecting XP to samba.

LawnBoy (MIS) 	
23 Nov 05 12:14
Do you also have a local account on that linux box where samba is running?
With SuSE 9 I had to setup both a local account AND a samba account with the
same user/pass.

hidden75 (IS/IT--Management) 	
23 Nov 05 15:02
post   global section from /etc/samba/smb.conf

heintze (Programmer) 	
24 Nov 05 14:37
Yes I have a local account. I've added the siegfried account to both fedora
core 4 and samba with the same password. I used smbpassword as described in
a previous post (above).


# Samba config file created using SWAT
# from (
# Date: 2005/11/19 23:58:35

# Global parameters
        workgroup = MYGROUP
        server string = Samba Server
        username map = /etc/samba/smbusers
        log file = /var/log/samba/%m.log
        max log size = 50
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        printcap name = /etc/printcap
        dns proxy = No
        idmap uid = 16777216-33554431
        idmap gid = 16777216-33554431
        cups options = raw

        comment = Home Directories
        read only = No
        browseable = No

        comment = All Printers
        path = /var/spool/samba
        printable = Yes
        browseable = No

        comment = sieg's home directory
        path = /home/siegfried
        username = siegfried
        valid users = siegfried, root
        admin users = siegfried, root
        write list = siegfried, root
        read only = No
        hosts allow =


stanhubble (MIS) 	
24 Nov 05 15:05
did you "enable" the user with smbpasswd?

smbpasswd -e siegfried

you may also have a conflict between the "homes" and the explicit definition
of siegfried.

hidden75 (IS/IT--Management) 	
24 Nov 05 15:20
Do a start, run,  \\

See if it pops up a list of shares or a password prompt or an error.

Post results.

heintze (Programmer) 	
24 Nov 05 15:34
Could you elaborate a bit? What exactly are the start, run commands you
suggest I use and where do I execute them? on windows XP or Fedore Core 4?

Stan Hubble,
Thanks -- I'll try that tonight. I gotta go to another dinner party.


smah (MIS) 	
24 Nov 05 17:30
Add: security = user to the global section & restart samba.  Incedentally,
what's in '/etc/samba/smbusers'?  If you have only the 1 user with a 1 word
username, there's no real benefit & unless there's something in your network
that you haven't told us about, comment out the idmap lines.

Thank smah
for this valuable post!

heintze (Programmer) 	
25 Nov 05 0:25
Still no luck.
  I added security=user and commented out the idmap lines. Is there
something I should do about /etc/samba/smbusers?
  I tried smbpasswd -e siegfried and it says "siegfried" is enabled. I also
verified the password.

Could there be a problem with the protection of /home/siegfried?

I tried creating another directory  and  "chown siegfried:siegfried
/home/siegfried2" and "chmod 777 /home/siegfried2" and pointed the directory
to siegfried2.

No luck.

Any other ideas?


rzs0502 (IS/IT--Management) 	
25 Nov 05 8:31
Make a backup copy of your smb.conf
Change it to the following example. If it still gives you problems, then it
could be a problem with the encryption used between XP and the Samba server.

        workgroup = MYGROUP
        update encrypted = Yes
        unix password sync = Yes
        client NTLMv2 auth = Yes
        client lanman auth = No
        client plaintext auth = No
        log file = /var/log/samba.log
        max log size = 100
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        preferred master = Yes
        idmap uid = 10000-20000
        idmap gid = 10000-20000
        comment = Home Directories
        read only = No
        browseable = No

"If you always do what you've always done, you will always be where
you've always been."

Thank rzs0502
for this valuable post!

heintze (Programmer) 	
25 Nov 05 9:38
I tried that by commenting everything and pasting in the above. Then I
restarted with

/etc/rc.d/init.d/smb restart

Connecting from XP Pro did not work. Don't I have to specify a legal path to
share in the smb.conf file?

Well, anyway, it produced the exact same errors on XP Pro as it did

It is interesting that I get different error messages depending on whether I
supply the username and password or let it prompt me. When I let it prompt
me, I get "System error 53 has occured. the network path was not found."
When I supply the user name and password on the command line I get "System
error 5 has occurred. Access is denied.".

Thanks for all the help so far!


stanhubble (MIS) 	
25 Nov 05 14:19
does the following work?

mount -t smbfs // /mnt/sales -o username=siegfried

if it does then the problem most likely is on the xp machine.
you could also have a iptable rule blocking it.

hidden75 (IS/IT--Management) 	
26 Nov 05 14:37
Sorry. On your windows box go to start , then run, and type \\

And then hit okay.

See if it pops up all your shares on your linux box.

You can see your Linux box in Network Places right?

heintze (Programmer) 	
26 Nov 05 19:29

I get a message box that says "\\ The networkpath was not
However, ping works fine!

I cannot see my linux box in network neighborhood. However, I can see the
workgroup "mygroup" which is defined in smb.conf.


mount -t smbfs // /mnt/work username=siegfried

works fine. I can see the shares.

Well it looks to me like Windows is having trouble seeing but it
can ping it. I don't understand.



hidden75 (IS/IT--Management) 	
27 Nov 05 4:48
Okay that is a problem.  do a ifconfig on your linux box and get the
interface name that your using for your LAN probably eth0 or eth1 or
something.  add interfaces = ethX to your global section of your smb.conf

Make sure you replace the X with the interface number you got from ifconfig.

Restart smb   /etc/init.d/smb restart

See if you can do the start, run, \\ or see it in Network Places.

I'm curious what windows OS your using also. XP Pro, Home? w2k?

Your windows box is setup with the exact name of the WORKGROUP correct?

hidden75 (IS/IT--Management) 	
27 Nov 05 4:58
One more thing.. You said you can't see the Linux box from Network Places.
Were you looking under your workgroup in Network Places?  You should see
your Linux box listed in My Network Places within your workgroup name.

heintze (Programmer) 	
27 Nov 05 18:23
Here is my ifconfig (see below). I tried adding "interfaces eth0" under the
global section but that did not help. I tried "interfaces" and
that did not work either.

start->run->\\ on the XP Pro wireless notebook (nodename=SALES)
gives the same results as before: "the network path cannot be found".
Windows 2000 (nodename=brauner) also gives these same results.

Concerning "My Network Places":
Network neighborhood for Win2000 shows "mygroup" but no members when I click
on it. It also shows the other computers under "workgroup" including SALES.

The wireless notebook running XP Pro shows (under My Network Places") an
empty workgroup called "Mobile HWI". That is very curious.

Brauner is clearly setup under workgroup="workgroup". I'm not sure about

So there is still something wrong with the samba configuration because
BRAUNER should be able to see not only the workgroup but the computer as


eth0      Link encap:Ethernet  HWaddr 00:11:09:89:D7:F9
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::211:9ff:fe89:d7f9/64 Scope:Link
          RX packets:173 errors:0 dropped:0 overruns:0 frame:0
          TX packets:221 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:147922 (144.4 KiB)  TX bytes:54311 (53.0 KiB)
          Interrupt:201 Memory:fbffc000-0

lo        Link encap:Local Loopback
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1910 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1910 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1827820 (1.7 MiB)  TX bytes:1827820 (1.7 MiB)


heintze (Programmer) 	
27 Nov 05 18:44
That was supposed to be "interfaces=eth0" not "interfaces eth0)".

I tried changing the workgroup name in the samba smb.conf from the default
of "mygroup" to "BATTLEGROUP" and this new change did not show up in the
network neighborhood for brauner. It still says "mygroup".

However, I just ran a little C program I wrote years ago that enumerates the
computers on the network. It does not cache like network neighborhood does.
Brauner shows the new workgroup "BATTLEGROUP" and the old workgroup
"mygroup" as both being empty workgroups. The new workgroup "BATTLEGROUP"
does not show up on SALES.

Both brauner and SALES can still ping successfully!


More information about the NCLUG mailing list