[NCLUG] rpm not recognizing library

Bob Proulx bob at proulx.com
Sat Dec 3 00:04:04 MST 2005

Sean Reifschneider wrote:
> bsimpson at att.net wrote:
> > error: Failed dependencies:
> >         libstdc++.so.2.8 is needed by pgp-6.5.2-free3-rsaref.i386
> >
> >I copied over libstdc++.so.2.8 into /usr/lib from a FC3 installation,
> >but I still get the same error.  My guess is that rpm wants to see it
> >in its own database.  How do I do this?

Package managers know about files that were installed with the package
management tools.  If you simply copy files around then that is going
outside of the package management process.  There is no way for the
rpm package manager to know that you copied that file over.  As far as
rpm is concerned that file is not installed.  The real way to install
that file would be to install the rpm package that contained that

> You probably want to rebuild pgp from src.rpm so that it uses the libraries
> you have installed, instead of clinging to an old binary RPM.

Yes.  If you have the src.rpm for the package you want to rebuild then
that is a reasonable way to proceed.

> compat-libstdc++ provides version 2.9, but that's not going to satisfy that
> dependency.
> How about switching to GPG instead?  It's included with FC4.

Agreed.  Use GPG instead.  Because I will hazard a guess that you
don't have the src.rpm for the pgp package that you were trying to
install.  Of course I am sure you can find it somewhere.  But
switching to GPG is a better choice in my opinion.


More information about the NCLUG mailing list